Views:

Issue:

Customers who believe they have received a defective cylinder from our company need to follow the instructions below to help us determine if the cylinder is indeed defective.

Cause:

information not provided in the case

Resolution:

To report a possible defective cylinder, please follow these steps:

  1. Gather the following information before proceeding:

    • Refrigerant Type
    • Refrigerant Size
    • Brand Name
    • Location of Product
    • Cylinder Serial Number
    • QC# and date (for Hudson brand cylinders)
    • Date received from Hudson
    • Description of defect
  2. Fill out the online claim form provided. You will receive a confirmation email after submitting your claim.

  3. Within 48-72 hours of receiving your claim, you will receive an email containing your claim number, bill of lading, and labels for the pickup of your defective cylinder. Please note that defective cylinders must be sent separately from reclaim shipments.

  4. Once the freight carrier picks up the cylinders, please confirm by emailing customerservice@hudsontech.com.

  5. After we receive the cylinder, it will undergo inspection for defects. If a defect is found, credit will be issued accordingly.

Please note the following:

  • For 30 & 50 lb. (DOT-39) cylinders, it is required to ship them inside a strong outer packaging, such as a box or crate. We recommend shipping the cylinder in its original packaging, as DOT regulations do not permit shipping these cylinders without their product-specific outer packaging.
  • Claims for empty or light-weight cylinders will not be considered unless the seal is intact at the time of return for inspection.
  • If you believe you have a refrigerant cylinder that is currently leaking, please refer to the provided information in the case.

For any questions regarding orders, shipments, cylinder returns, or other inquiries, please contact our Customer Support Portal or reach out to us via phone at 800-277-3490.